<!DOCTYPE html>
<html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#">
<head>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-P39PZPH');</script>
<!-- End Google Tag Manager -->

  <meta charset="UTF-8">
  <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <meta property="twitter:account_id" content="4503599627387949" />
  
  <link type="image/x-icon" rel="shortcut icon" href="/favicon.ico?v=1">
  <script type="text/javascript">
    var ajaxUrl = 'https://alabamanewscenter.com';
  </script>

  
<!-- This site is optimized with the Yoast SEO plugin v6.0 - https://yoast.com/wordpress/plugins/seo/ -->
<title>On this day in Alabama history: Neil Bonnett makes NASCAR debut - Alabama NewsCenter</title>
<link rel="canonical" href="https://alabamanewscenter.com/2019/05/05/day-alabama-history-neil-bonnett-makes-nascar-debut/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="On this day in Alabama history: Neil Bonnett makes NASCAR debut - Alabama NewsCenter" />
<meta property="og:description" content="The Ensley native was a well-known race car driver who won 18 NASCAR events in the 1970s and 1980s." />
<meta property="og:url" content="https://alabamanewscenter.com/2019/05/05/day-alabama-history-neil-bonnett-makes-nascar-debut/" />
<meta property="og:site_name" content="Alabama NewsCenter" />
<meta property="article:publisher" content="https://www.facebook.com/AlabamaPower" />
<meta property="article:tag" content="Alabama 200" />
<meta property="article:tag" content="Alabama Sports Hall of Fame" />
<meta property="article:tag" content="Ensley" />
<meta property="article:tag" content="International Motorsports Hall of Fame" />
<meta property="article:tag" content="NASCAR" />
<meta property="article:tag" content="Neil Bonnett" />
<meta property="article:tag" content="Sprint Cup Series" />
<meta property="article:tag" content="This Day in Alabama History" />
<meta property="article:tag" content="Winston Cup Series" />
<meta property="article:section" content="Community" />
<meta property="article:published_time" content="2019-05-05T07:50:08-05:00" />
<meta property="article:modified_time" content="2019-05-02T16:10:55-05:00" />
<meta property="og:updated_time" content="2019-05-02T16:10:55-05:00" />
<meta property="og:image" content="https://alabamanewscenter.com/wp-content/uploads/2019/05/May-5-feature.jpg" />
<meta property="og:image:secure_url" content="https://alabamanewscenter.com/wp-content/uploads/2019/05/May-5-feature.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="360" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/alabamanewscenter.com\/","name":"Alabama News Center","potentialAction":{"@type":"SearchAction","target":"https:\/\/alabamanewscenter.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//maps.google.com' />
<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Alabama NewsCenter &raquo; Feed" href="https://alabamanewscenter.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Alabama NewsCenter &raquo; Comments Feed" href="https://alabamanewscenter.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/alabamanewscenter.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.10"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://alabamanewscenter.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css?ver=4.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-parsely-style-css'  href='https://alabamanewscenter.com/wp-content/plugins/wp-parsely/wp-parsely.css?ver=1452890566' type='text/css' media='all' />
<link rel='stylesheet' id='wp-polls-css'  href='https://alabamanewscenter.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.2' type='text/css' media='all' />
<style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://alabamanewscenter.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='_apcnews-main-css'  href='https://alabamanewscenter.com/wp-content/themes/news/assets/css/app.min.css?ver=20190505' type='text/css' media='all' />
<link rel='stylesheet' id='_apcnews-colors-css'  href='https://alabamanewscenter.com/wp-admin/admin-ajax.php?action=apn_dynamic_css&#038;ver=4.9.10' type='text/css' media='' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://alabamanewscenter.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.1.1' type='text/css' media='all' />
<script type='text/javascript' src='https://alabamanewscenter.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/alabamanewscenter.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"180320","token":"c2fe332dc0","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.2.0.min.js?ver=4.2.2'></script>
<link rel='https://api.w.org/' href='https://alabamanewscenter.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://alabamanewscenter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falabamanewscenter.com%2F2019%2F05%2F05%2Fday-alabama-history-neil-bonnett-makes-nascar-debut%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://alabamanewscenter.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Falabamanewscenter.com%2F2019%2F05%2F05%2Fday-alabama-history-neil-bonnett-makes-nascar-debut%2F&#038;format=xml" />
<link rel='https://github.com/WP-API/WP-API' href='https://alabamanewscenter.com/wp-json' />
<script type="text/javascript">
	window._se_plugin_version = '8.1.9';
</script>

<!-- BEGIN wp-parsely Plugin Version 1.14 -->
<meta name="wp-parsely_version" id="wp-parsely_version" content="1.14"/>
			<script type="application/ld+json">
		{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/alabamanewscenter.com\/2019\/05\/05\/day-alabama-history-neil-bonnett-makes-nascar-debut\/"},"headline":"On this day in Alabama history: Neil Bonnett makes NASCAR debut","url":"http:\/\/alabamanewscenter.com\/2019\/05\/05\/day-alabama-history-neil-bonnett-makes-nascar-debut\/","thumbnailUrl":"https:\/\/alabamanewscenter.com\/wp-content\/uploads\/2019\/05\/May-5-feature-150x150.jpg","image":{"@type":"ImageObject","url":"https:\/\/alabamanewscenter.com\/wp-content\/uploads\/2019\/05\/May-5-feature-150x150.jpg"},"dateCreated":"2019-05-05T17:50:08Z","datePublished":"2019-05-05T17:50:08Z","dateModified":"2019-05-05T17:50:08Z","articleSection":"Community","author":[{"@type":"Person","name":"Erin Harney"}],"creator":["Erin Harney"],"keywords":["alabama 200","alabama sports hall of fame","ensley","international motorsports hall of fame","nascar","neil bonnett","sprint cup series","this day in alabama history","winston cup series"],"publisher":{"@type":"Organization","name":"Alabama NewsCenter","logo":{"@type":"ImageObject","url":""}}}
		</script>

			<!-- END wp-parsely Plugin Version 1.14 -->

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://alabamanewscenter.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="icon" href="https://alabamanewscenter.com/wp-content/uploads/2016/06/cropped-icon-555cd84fv1_site_icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://alabamanewscenter.com/wp-content/uploads/2016/06/cropped-icon-555cd84fv1_site_icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://alabamanewscenter.com/wp-content/uploads/2016/06/cropped-icon-555cd84fv1_site_icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://alabamanewscenter.com/wp-content/uploads/2016/06/cropped-icon-555cd84fv1_site_icon-270x270.png" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>
  <!--[if lt IE 9]>
    <script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.2/html5shiv.min.js"></script>
    <script src="//cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
  <![endif]-->
</head>

<body class="post-template-default single single-post postid-180320 single-format-standard section-community  is-desktop wpb-js-composer js-comp-ver-5.4.5 vc_responsive">

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-P39PZPH"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

   <!-- Adobe DTM -->
   <script src="//assets.adobedtm.com/b529c88e7e7aec8dcab31cf2026351aad2e6ab08/satelliteLib-84db8f3ae80dfd381feecbd6b3a04c8dbc05743f.js"></script>

    <header class="main-header" id="global-header">

    <div class="secondary-bar">

      <div class="container-fluid">

        <div class="row">

          <div class="col-xs-6 logo-nav-wrap">
            <div class="site-logo" id="site-logo"><a href="/"><img src="https://alabamanewscenter.com/wp-content/themes/news/assets/images/logo-alabama-newscenter.png" class="logo-main" alt="Alabama NewsCenter" /></a></div>

              <!-- mclude apn_wt3tc_nocache wp-content/themes/news/templates/include-weather-widget.php --><!-- /mclude apn_wt3tc_nocache -->
              
      <div class="weather-widget" id="weather-widget-wrap">
        <span class="location">Birmingham</span>
        <span class="conditions icon-partlycloudy">68&deg;</span>
        <span class="weather-controls"></span>
        <div class="location-control-wrap">
          <form action="https://alabamanewscenter.com" method="POST">
            <input id="places-autocomplete" type="text" size="50">
            <input name="current-url" type="hidden" value="https://alabamanewscenter.com/2019/05/05/day-alabama-history-neil-bonnett-makes-nascar-debut?year=2019&monthnum=05&day=05&name=day-alabama-history-neil-bonnett-makes-nascar-debut" >
          </form>
          <span class="weather-controls-close"></span>
        </div>
      </div><h2 class="mobile-label">Community</h2><a class="mobile-share" href="#share-block">Share</a>          </div><!-- /.logo-nav-wrap -->

          <div class="col-xs-6 secondary-nav-wrap">

                          <a class="search icon-search" href="/?s="></a>
              <div class="search-inner-wrap">
                

  <div class="search-input-wrap">
    <form role="search" method="get" id="search-form" class="search-form" action="https://alabamanewscenter.com/">
      <label for="s" class="search-label"></label>
      <input type="search" class="search-field" id="s" placeholder="Search" value="" name="s" />
      <input type="hidden" name="cat" id="cat" value="" />
      <button type="submit" class="btn btn-submit btn-search" value="Search" data-ga-category="Global_Header" data-ga-label="SearchSite" data-ga-action="Click">Search</button>
    </form>
  </div>




              </div><!-- /.search-inner-wrap -->
              

            <ul class="header-menu-secondary" id="secondary-nav-menu">
              <li class="menu-smartneighbor"><a href="https://www.smartneighbor.com/" data-ga-category="Global_Menu" data-ga-action="Click" data-ga-label="Smartneighbor">Smartneighbor</a></li>
<li class="menu-developed-by-alabama-power"><a href="http://alabamapower.com/" data-ga-category="Global_Menu" data-ga-action="Click" data-ga-label="Developed_By_Alabama_Power">Developed by Alabama Power</a></li>
            </ul>

            <ul class="social-nav" id="header-social-nav">
                        </ul>

          </div><!-- /.secondary-nav-wrap -->
          <span class="btn-menu" id="btn-menu">Menu</span>
        </div><!-- /.row -->

      </div><!-- /.container-fluid -->

    </div><!-- ./secondary-bar -->

    <div class="primary-bar" id="primary-bar">

      <div class="container-fluid">
        <div class="row">
          <div class="col-md-12">
                          <div class="mobile-search">
                <a class="search icon-search-mobile" href="/?s="></a>
                <div class="search-mobile-wrap">
                  

  <div class="search-input-wrap">
    <form role="search" method="get" id="search-form" class="search-form" action="https://alabamanewscenter.com/">
      <label for="s" class="search-label"></label>
      <input type="search" class="search-field" id="s" placeholder="Search" value="" name="s" />
      <input type="hidden" name="cat" id="cat" value="" />
      <button type="submit" class="btn btn-submit btn-search" value="Search" data-ga-category="Global_Header" data-ga-label="SearchSite" data-ga-action="Click">Search</button>
    </form>
  </div>




                </div><!-- /.search-inner-wrap -->
              </div>
                          <ul class="header-menu-primary" id="primary-nav-menu">
                            
      <li class="menu-business" data-cat="business">
      <a class="cat-head" href="https://alabamanewscenter.com/category/business/" data-ga-category="Global_Menubar" data-ga-action="Click" data-ga-label="Business">Business</a></li>

      <li class="current-post-ancestor active current-post-parent menu-community" data-cat="community">
      <a class="cat-head" href="https://alabamanewscenter.com/category/community/" data-ga-category="Global_Menubar" data-ga-action="Click" data-ga-label="Community">Community</a></li>

      <li class="menu-innovation" data-cat="innovation">
      <a class="cat-head" href="https://alabamanewscenter.com/category/innovation/" data-ga-category="Global_Menubar" data-ga-action="Click" data-ga-label="Innovation">Innovation</a></li>

      <li class="menu-weather-center" data-cat="weather-center">
      <a class="cat-head" href="https://alabamanewscenter.com/category/weather-center/" data-ga-category="Global_Menubar" data-ga-action="Click" data-ga-label="Weather_Center">Weather Center</a></li>

      <li class="menu-about-us">
      <a href="https://alabamanewscenter.com/about-us/" data-ga-category="Global_Menubar" data-ga-action="Click" data-ga-label="About_Us">About Us</a></li>
            </ul>
            <ul class="mobile-utility">
              <li class="menu-smartneighbor"><a href="https://www.smartneighbor.com/" data-ga-category="Global_Menu" data-ga-action="Click" data-ga-label="Smartneighbor">Smartneighbor</a></li>
<li class="menu-developed-by-alabama-power"><a href="http://alabamapower.com/" data-ga-category="Global_Menu" data-ga-action="Click" data-ga-label="Developed_By_Alabama_Power">Developed by Alabama Power</a></li>
            </ul>
            <div class="last-posts">
              
          <ul class="category-top-posts category-business">
            <li><a href="https://alabamanewscenter.com/2019/05/04/athens-area-median-sales-price-up-from-one-year-ago/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/HouseBarFeature-320x180.jpg" class="top-post-thumb" alt="" /></span>Athens-area home sales up 16 percent from one year ago</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/02/gadsden-median-sales-price-up-significantly-from-one-year-ago/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/Downtown-Gadsden-Feature-320x180.jpg" class="top-post-thumb" alt="" /></span>Gadsden median home sales price up 15 percent from one year ago</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/02/georgia-pacific-to-invest-120-million-in-choctaw-county-mill/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/GP-Feature-320x180.jpg" class="top-post-thumb" alt="" /></span>Georgia-Pacific to invest $120 million in Choctaw County mill</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/02/alabama-team-launches-bio-focused-trade-mission-to-ireland-uk/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/04/Bio-Feature-New-320x180.jpg" class="top-post-thumb" alt="" /></span>Alabama team launches bioscience-focused trade mission to Ireland, UK</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/01/huntsville-sales-up-9-4-percents-from-last-month/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/04/Huntsville-Home-Feature-320x180.jpg" class="top-post-thumb" alt="" /></span>Huntsville median home sales price up 6 percent from a year ago</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/01/construction-begins-new-fan-garage-experience-talladega-superspeedway/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/04/Dega-Phase-2-Begins-FEATURE-320x180.jpg" class="top-post-thumb" alt="" /></span>Construction begins on new fan garage experience at Talladega Superspeedway</a>
            </li>
            
          </ul>
        
          <ul class="category-top-posts category-community">
            <li><a href="https://alabamanewscenter.com/2019/05/04/recipe-pizza-sausage-balls/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/04/Pizza_Sausage_Balls_Featured-320x180.jpg" class="top-post-thumb" alt="" /></span>Recipe: Pizza Sausage Balls</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/04/day-alabama-history-research-institute-renamed-reflect-new-purpose/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/May-4-feature-320x180.jpg" class="top-post-thumb" alt="" /></span>On this day in Alabama history: Research institute renamed to reflect new purpose</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/03/cheeriodicals-regions-tradition-partner-bring-mothers-day-joy-childrens-alabama/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/CheeriodicalsFeature-320x180.jpg" class="top-post-thumb" alt="" /></span>Cheeriodicals, Regions Tradition partner to bring Mother’s Day joy to Children’s of Alabama</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/03/keli-wright-is-an-alabama-bright-light-hatching-hope/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/Hatching-Hope-Feature-320x180.jpg" class="top-post-thumb" alt="" /></span>Keli Wright is an Alabama Bright Light Hatching Hope</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/03/student-powered-produce-stand-opens-birminghams-woodlawn-high-school/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/JV-Farm-Stand-FEATURE-320x180.jpg" class="top-post-thumb" alt="" /></span>Student-powered produce stand opens at Birmingham's Woodlawn High School</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/03/day-alabama-history-george-c-wallace-state-technical-junior-college-created/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/May-3-feature-3-320x180.jpg" class="top-post-thumb" alt="" /></span>On this day in Alabama history: George C. Wallace State Technical Junior College was created</a>
            </li>
            
          </ul>
        
          <ul class="category-top-posts category-innovation">
            <li><a href="https://alabamanewscenter.com/2019/05/03/southern-researchs-airs-technology-records-spacecrafts-return-for-nasa/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/AIRS-Feature-320x180.jpg" class="top-post-thumb" alt="" /></span>Southern Research's AIRS technology records spacecraft's return for NASA</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/02/alabama-team-launches-bio-focused-trade-mission-to-ireland-uk/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/04/Bio-Feature-New-320x180.jpg" class="top-post-thumb" alt="" /></span>Alabama team launches bioscience-focused trade mission to Ireland, UK</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/01/coalition-encourages-alabama-expand-high-speed-internet-access/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/Rural-Broadband-FEATURE-320x180.jpg" class="top-post-thumb" alt="" /></span>Coalition encourages Alabama to expand high-speed internet access</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/01/reference-genome-peanut-will-help-improve-one-alabamas-biggest-crops/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/PeanutFeature-320x180.jpg" class="top-post-thumb" alt="" /></span>Reference genome for the peanut will help improve one of Alabama’s biggest crops</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/04/25/montgomery-wins-2019-smart-cities-readiness-challenge/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/04/MGM-Feature-320x180.jpg" class="top-post-thumb" alt="" /></span>Montgomery wins 2019 Smart Cities Readiness Challenge</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/04/24/179042/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/04/EV-Feature-320x180.jpg" class="top-post-thumb" alt="" /></span>Alabama EV charging station grant program could provide model for nation</a>
            </li>
            
          </ul>
        
          <ul class="category-top-posts category-weather-center">
            <li><a href="https://alabamanewscenter.com/2019/05/04/scott-martin-potential-for-strong-to-severe-storms-in-alabama-today-2/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/martinz-320x180.png" class="top-post-thumb" alt="" /></span>Scott Martin: Potential for strong to severe storms in Alabama today</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/03/james-spann-724/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/Capturezzzzzzzzzzzz-320x180.jpg" class="top-post-thumb" alt="" /></span>James Spann: Scattered strong storms for Alabama on Saturday</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/03/james-spann-723/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/AL_swody2-320x180.png" class="top-post-thumb" alt="" /></span>James Spann: Warm May days for Alabama, with a few strong storms Saturday</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/02/james-spann-722/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/Screen-Shot-2019-05-02-at-3_23_00-PM-320x180.png" class="top-post-thumb" alt="" /></span>James Spann: Warm afternoon for Alabama, with widely scattered showers</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/02/james-spann-721/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/spazz-320x180.png" class="top-post-thumb" alt="" /></span>James Spann: Summer-like pattern continues in Alabama</a>
            </li>
            
            <li><a href="https://alabamanewscenter.com/2019/05/01/james-spann-720/"><span class="category-image-wrap"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/spamm-320x180.jpg" class="top-post-thumb" alt="" /></span>James Spann: Warm early May weather continues in Alabama</a>
            </li>
            
          </ul>
                    </div>

          </div><!-- ./column -->
        </div><!-- ./row -->
      </div><!-- ./container-fluid -->


    </div><!-- /.primary-bar -->
  </header>

    <div class="back-wrap">
    <div id="site-content" class="container-fluid content-wrap">
      <div class="row content-row">
        <!--[if lt IE 9]>
          <div class="browser-update">
            Your browser appears to be out-of-date. Please <a href="https://browser-update.org/update.html" target="_blank" data-ga-event="LP_Global" data-ga-cat="click" data-ga-label="Upgrade Browser">download one of these free browsers</a> for a better NewsCenter website experience.
          </div>
        <![endif]-->

<div class="page-wrap col-sm-8">

  
  
    
<article id="post-180320" class="post-single post-180320 post type-post status-publish format-standard has-post-thumbnail hentry category-community tag-alabama-200 tag-alabama-sports-hall-of-fame tag-ensley tag-international-motorsports-hall-of-fame tag-nascar tag-neil-bonnett tag-sprint-cup-series tag-this-day-in-alabama-history tag-winston-cup-series">

	<header class="entry-header">
    
    	<div class="entry-sharing" id="share-block">

		  
	<ul class="share-links ">
	  <li class="share-text">Share this story</li>
	  <li class="fb"><a class="share-link" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Falabamanewscenter.com%2F2019%2F05%2F05%2Fday-alabama-history-neil-bonnett-makes-nascar-debut%2F" data-ga-category="Post_Share_Facebook" data-ga-label="On_This_Day_In_Alabama_History_Neil_Bonnett_Makes_Nascar_Debut" data-ga-action="Click" title="Share on Facebook"><span class="share-count"></span></a></li>
	  <li class="tw"><a class="share-link" href="https://twitter.com/intent/tweet?text=On%20this%20day%20in%20Alabama%20history%3A%20Neil%20Bonnett%20makes%20NASCAR%20debut&amp;url=https%3A%2F%2Falabamanewscenter.com%2F2019%2F05%2F05%2Fday-alabama-history-neil-bonnett-makes-nascar-debut%2F&amp;related=alabamapower" data-ga-category="Post_Share_Twitter" data-ga-label="On_This_Day_In_Alabama_History_Neil_Bonnett_Makes_Nascar_Debut" data-ga-action="Click" title="Share on Twitter"><span class="share-count"></span></a></li>
	  <li class="gp"><a class="share-link" href="https://plus.google.com/share?url=https%3A%2F%2Falabamanewscenter.com%2F2019%2F05%2F05%2Fday-alabama-history-neil-bonnett-makes-nascar-debut%2F" data-ga-category="Post_Share_Google" data-ga-label="On_This_Day_In_Alabama_History_Neil_Bonnett_Makes_Nascar_Debut" data-ga-action="Click" title="Share on Google+"><span class="share-count"></span></a></li>
	  <li class="li"><a class="share-link" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Falabamanewscenter.com%2F2019%2F05%2F05%2Fday-alabama-history-neil-bonnett-makes-nascar-debut%2F&amp;title=On%20this%20day%20in%20Alabama%20history%3A%20Neil%20Bonnett%20makes%20NASCAR%20debut" data-ga-category="Post_Share_LinkedIn" data-ga-label="On_This_Day_In_Alabama_History_Neil_Bonnett_Makes_Nascar_Debut" data-ga-action="Click" title="Share on LinkedIn"><span class="share-count"></span></a></li>
	  <li class="em"><a class="share-link-email" target="_blank" href="/cdn-cgi/l/email-protection#56693439322f6b3e22222625736517736410736410373a3734373b37383321253533382233247835393b7364106466676f7364106663736410666373641032372f7b373a3734373b377b3e3f252239242f7b38333f3a7b343938383322227b3b373d33257b3837253537247b3233342322736410702523343c3335226b193876223e3f257632372f763f3876173a3734373b37763e3f252239242f6c7618333f3a7614393838332222763b373d332576181705151704763233342322" displayText="email" data-ga-category="Post_Share_Email" data-ga-label="On_This_Day_In_Alabama_History_Neil_Bonnett_Makes_Nascar_Debut" data-ga-action="Click" title="Share via Email"></a></li>
	  <li class="lk"><a class="copy-link" data-ga-category="Post_Share_CopyLink" data-ga-label="On_This_Day_In_Alabama_History_Neil_Bonnett_Makes_Nascar_Debut" data-ga-action="Click" title="Copy Story Link"></a>
		<div class="copy-popup">
		  <i class="fa fa-times copy-close"></i>
		  <h6>Permalink</h6>
		  <!-- <p>CTRL + C (⌘ + C for Mac)</p> -->
		  <input id="copy-url" type="text" value="" />
		</div>
	  </li>
	</ul>
		</div><!-- .entry-sharing -->
		
		<h1 class="entry-title">On this day in Alabama history: Neil Bonnett makes NASCAR debut</h1>
				
		<p class="entry-author">By Alabama NewsCenter Staff</p>
		
		<div class="entry-meta">
		  <time class="entry-date published">
			May 5, 2019			
		  </time>
		</div><!-- .entry-meta -->
		
	
	</header>

  <div class="entry-hero"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/05/May-5-feature.jpg" alt="On this day in Alabama history: Neil Bonnett makes NASCAR debut"/><figcaption class="wp-caption-text">NASCAR driver Neil Bonnett signing autographs, 2008. (Ted Van Pelt, Wikipedia) </figcaption></div>

  <div class="entry-content">

    <div class="entry-content-inner">

      <blockquote><p><strong>May 5, 1974</strong></p></blockquote>
<p>On May 5, 1974, Neil Bonnett, who had already been successfully competing on short-track raceways across the Southeast, made his debut in NASCAR’s premier division, the Winston Cup Series (now the Sprint Cup Series) in the Winston 500 at Talladega Superspeedway. Because of engine problems, he completed only 51 of the 188 laps, finishing 45<sup>th</sup> in the race. Undaunted, he continued competing and placed fifth in the Daytona 500 the next year. His first two Winston Cup Circuit wins were the Capital City 400 at Richmond International Raceway on Sept. 11, 1977, and the Los Angeles Times 500 in Ontario, California, two months later. From 1979 to 1983, Bonnett won 11 Winston Cup races, including at Talladega in 1980. Bonnett’s most successful season was 1985, when he won twice and finished in the top 10 in 28 events. He was a member of the famed Alabama Gang, a group of successful stock car racers who operated out of the Hueytown area. Bonnett’s racing career ended after he was injured in a 14-car crash at Darlington Raceway. Bonnett retired from racing and began a career as a television sports commentator. Born in Ensley on July 30, 1946, Bonnett was named one of the 50 greatest drivers of the first 50 years of NASCAR. He was posthumously inducted into the Alabama Sports Hall of Fame, the National Motorsports Press Association Hall of Fame and the International Motorsports Hall of Fame.</p>
<p><em>Read more at<a href="http://www.encyclopediaofalabama.org/article/h-2441"> Encyclopedia of Alabama</a>.</em></p>
<div class="tiled-gallery type-rectangular tiled-gallery-unresized" data-original-width="900" data-carousel-extra='{&quot;blog_id&quot;:1,&quot;permalink&quot;:&quot;https:\/\/alabamanewscenter.com\/2019\/05\/05\/day-alabama-history-neil-bonnett-makes-nascar-debut\/&quot;,&quot;likes_blog_id&quot;:91832812}' itemscope itemtype="http://schema.org/ImageGallery" > <div class="gallery-row" style="width: 900px; height: 426px;" data-original-width="900" data-original-height="426" > <div class="gallery-group images-1" style="width: 568px; height: 426px;" data-original-width="568" data-original-height="426" > <div class="tiled-gallery-item tiled-gallery-item-large" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://i1.wp.com/alabamanewscenter.com/wp-content/uploads/2019/05/m-8071.jpg?ssl=1" border="0" itemprop="url"> <meta itemprop="width" content="564"> <meta itemprop="height" content="422"> <img data-attachment-id="180323" data-orig-file="https://alabamanewscenter.com/wp-content/uploads/2019/05/m-8071.jpg" data-orig-size="387,290" data-comments-opened="" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;bn&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Neil Bonnett 1982 File Photo&quot;,&quot;created_timestamp&quot;:&quot;389145600&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;NEIL BONNETT&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="NEIL BONNETT" data-image-description="" data-medium-file="https://alabamanewscenter.com/wp-content/uploads/2019/05/m-8071.jpg" data-large-file="https://alabamanewscenter.com/wp-content/uploads/2019/05/m-8071.jpg" src="https://i1.wp.com/alabamanewscenter.com/wp-content/uploads/2019/05/m-8071.jpg?w=564&#038;h=422&#038;ssl=1" width="564" height="422" data-original-width="564" data-original-height="422" itemprop="http://schema.org/image" title="NEIL BONNETT" alt="Ensley native Neil Bonnett (1946-1994) was a member of the Alabama Gang, popular NASCAR drivers based out of Hueytown that included the Allison brothers. Bonnett won 18 NASCAR events before dying during a practice session at Daytona International Speedway. (From Encyclopedia of Alabama, courtesy of The Birmingham News)" style="width: 564px; height: 422px;" /> </a> <div class="tiled-gallery-caption" itemprop="caption description"> Ensley native Neil Bonnett (1946-1994) was a member of the Alabama Gang, popular NASCAR drivers based out of Hueytown that included the Allison brothers. Bonnett won 18 NASCAR events before dying during a practice session at Daytona International Speedway. (From Encyclopedia of Alabama, courtesy of The Birmingham News) </div> </div> </div> <!-- close group --> <div class="gallery-group images-2" style="width: 332px; height: 426px;" data-original-width="332" data-original-height="426" > <div class="tiled-gallery-item tiled-gallery-item-large" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://i2.wp.com/alabamanewscenter.com/wp-content/uploads/2019/05/m-8072.jpg?ssl=1" border="0" itemprop="url"> <meta itemprop="width" content="328"> <meta itemprop="height" content="246"> <img data-attachment-id="180324" data-orig-file="https://alabamanewscenter.com/wp-content/uploads/2019/05/m-8072.jpg" data-orig-size="387,290" data-comments-opened="" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="m-8072" data-image-description="" data-medium-file="https://alabamanewscenter.com/wp-content/uploads/2019/05/m-8072.jpg" data-large-file="https://alabamanewscenter.com/wp-content/uploads/2019/05/m-8072.jpg" src="https://i2.wp.com/alabamanewscenter.com/wp-content/uploads/2019/05/m-8072.jpg?w=328&#038;h=246&#038;ssl=1" width="328" height="246" data-original-width="328" data-original-height="246" itemprop="http://schema.org/image" title="m-8072" alt="Racecar driver Neil Bonnett, left, poses with fellow Alabama Gang members Bobby, right, and Donnie Allison. The Alabama Gang, centered in Hueytown, was a successful group of NASCAR drivers during the 1970s and 1980s. (From Encyclopedia of Alabama, courtesy of the Alabama Sports Hall of Fame)" style="width: 328px; height: 246px;" /> </a> <div class="tiled-gallery-caption" itemprop="caption description"> Racecar driver Neil Bonnett, left, poses with fellow Alabama Gang members Bobby, right, and Donnie Allison. The Alabama Gang, centered in Hueytown, was a successful group of NASCAR drivers during the 1970s and 1980s. (From Encyclopedia of Alabama, courtesy of the Alabama Sports Hall of Fame) </div> </div> <div class="tiled-gallery-item tiled-gallery-item-large" itemprop="associatedMedia" itemscope itemtype="http://schema.org/ImageObject"> <a href="https://i2.wp.com/alabamanewscenter.com/wp-content/uploads/2019/05/NeilBonnett75racecar1983.jpg?ssl=1" border="0" itemprop="url"> <meta itemprop="width" content="328"> <meta itemprop="height" content="172"> <img data-attachment-id="180327" data-orig-file="https://alabamanewscenter.com/wp-content/uploads/2019/05/NeilBonnett75racecar1983.jpg" data-orig-size="1136,596" data-comments-opened="" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="NeilBonnett75racecar1983" data-image-description="" data-medium-file="https://alabamanewscenter.com/wp-content/uploads/2019/05/NeilBonnett75racecar1983-500x262.jpg" data-large-file="https://alabamanewscenter.com/wp-content/uploads/2019/05/NeilBonnett75racecar1983-1024x537.jpg" src="https://i2.wp.com/alabamanewscenter.com/wp-content/uploads/2019/05/NeilBonnett75racecar1983.jpg?w=328&#038;h=172&#038;ssl=1" width="328" height="172" data-original-width="328" data-original-height="172" itemprop="http://schema.org/image" title="NeilBonnett75racecar1983" alt="The RahMoc Enterprises-owned No. 75 Chevy of Neil Bonnett at the 1983 Van Scoy 500, 2007. (us44mt, Wikipedia)" style="width: 328px; height: 172px;" /> </a> <div class="tiled-gallery-caption" itemprop="caption description"> The RahMoc Enterprises-owned No. 75 Chevy of Neil Bonnett at the 1983 Van Scoy 500, 2007. (us44mt, Wikipedia) </div> </div> </div> <!-- close group --> </div> <!-- close row --> </div>
<p><em>For more on Alabama’s Bicentennial, visit <a href="http://alabama200.org/">Alabama 200</a>.</em></p>


      <div class="entry-footer-meta"></div>

    </div>
    <div class="entry-tags">

    
    </div><!-- .entry-tags -->

  </div><!-- .entry-content -->

</article><!-- #post-## -->

<div class="entry-nav">

  
	<div id="post-nav" class="nav-block-wrap row">
	<div class="nav-block col-xs-6">
	  <div class="nav-body">
	  <h6><span class="em em-innovation">innovation</span></h6>
	  <p class="cat-innovation"><a href="https://alabamanewscenter.com/2019/05/04/university-of-alabama-researchers-receive-grants-to-discover-new-ways-to-communicate-weather-alerts/" data-ga-category="Post_Widget_Nav" data-ga-label="University_Of_Alabama_Researchers_Win_Grants_To_Find_New_Ways_To_Communicate_Weather_Alerts" data-ga-action="Click">University of Alabama researchers win grants to find new ways to communicate weather alerts</a></p>
	  <a href="https://alabamanewscenter.com/2019/05/04/university-of-alabama-researchers-receive-grants-to-discover-new-ways-to-communicate-weather-alerts/" class="nav-link nav-prev nav-innovation" data-ga-category="Post_Widget_Nav" data-ga-label="PrevStory" data-ga-action="Click"><span>Prev Story</span></a>
	  
	  </div>
	</div>
	<div class="nav-block col-xs-6">
	  <div class="nav-body">
	  <h6><span class="em em-business">business</span></h6>
	  <p class="cat-business"><a href="https://alabamanewscenter.com/2019/05/05/marshall-county-home-sales-continue-to-rise-in-march/" data-ga-category="Post_Widget_Nav" data-ga-label="Marshall_County_Home_Sales_Prices_Continue_To_Rise" data-ga-action="Click">Marshall County home sales, prices continue to rise</a></p>
	  <a href="https://alabamanewscenter.com/2019/05/05/marshall-county-home-sales-continue-to-rise-in-march/" class="nav-link nav-next nav-business" data-ga-category="Post_Widget_Nav" data-ga-label="NextStory" data-ga-action="Click"><span>Next Story</span></a>
	  
	  </div>
	</div></div>
</div><!-- .entry-nav -->



	  <div class="entry-related">
		<h3>Related Stories</h3>
		<ul class="related-posts">
		
		  <li class="media">
			<a href="https://alabamanewscenter.com/2019/05/04/day-alabama-history-research-institute-renamed-reflect-new-purpose/" class="pull-left" data-ga-category="Post_Widget_Related" data-ga-label="On_This_Day_In_Alabama_History_Research_Institute_Renamed_To_Reflect_New_Purpose" data-ga-action="Click"><img class="media-object" src="https://alabamanewscenter.com/wp-content/uploads/2019/05/May-4-feature-320x180.jpg" alt="" /></a>
			<div class="media-body">
			  <h6><span class="em em-community">Community</span></h6>
			  <a href="https://alabamanewscenter.com/2019/05/04/day-alabama-history-research-institute-renamed-reflect-new-purpose/" data-ga-category="Post_Widget_Related" data-ga-label="On_This_Day_In_Alabama_History_Research_Institute_Renamed_To_Reflect_New_Purpose" data-ga-action="Click">On this day in Alabama history: Research institute renamed to reflect new purpose</a>
			  <p>The Alabama Research Institute became Southern Research Institute.</p>
			</div>
		  </li>
		  <li class="media">
			<a href="https://alabamanewscenter.com/2019/05/03/day-alabama-history-george-c-wallace-state-technical-junior-college-created/" class="pull-left" data-ga-category="Post_Widget_Related" data-ga-label="On_This_Day_In_Alabama_History_George_C_Wallace_State_Technical_Junior_College_Was_Created" data-ga-action="Click"><img class="media-object" src="https://alabamanewscenter.com/wp-content/uploads/2019/05/May-3-feature-3-320x180.jpg" alt="" /></a>
			<div class="media-body">
			  <h6><span class="em em-community">Community</span></h6>
			  <a href="https://alabamanewscenter.com/2019/05/03/day-alabama-history-george-c-wallace-state-technical-junior-college-created/" data-ga-category="Post_Widget_Related" data-ga-label="On_This_Day_In_Alabama_History_George_C_Wallace_State_Technical_Junior_College_Was_Created" data-ga-action="Click">On this day in Alabama history: George C. Wallace State Technical Junior College was created</a>
			  <p>George C. Wallace Community College is among the oldest community colleges in Alabama.</p>
			</div>
		  </li>
		  <li class="media">
			<a href="https://alabamanewscenter.com/2019/05/02/day-alabama-history-jefferson-county-settler-warren-truss-born/" class="pull-left" data-ga-category="Post_Widget_Related" data-ga-label="On_This_Day_In_Alabama_History_Jefferson_County_Settler_Warren_Truss_Was_Born" data-ga-action="Click"><img class="media-object" src="https://alabamanewscenter.com/wp-content/uploads/2019/05/May-2-feature-320x180.jpg" alt="" /></a>
			<div class="media-body">
			  <h6><span class="em em-community">Community</span></h6>
			  <a href="https://alabamanewscenter.com/2019/05/02/day-alabama-history-jefferson-county-settler-warren-truss-born/" data-ga-category="Post_Widget_Related" data-ga-label="On_This_Day_In_Alabama_History_Jefferson_County_Settler_Warren_Truss_Was_Born" data-ga-action="Click">On this day in Alabama history: Jefferson County settler Warren Truss was born</a>
			  <p>North Carolina native Warren Truss (1772-1837) was the namesake of the city of Trussville.</p>
			</div>
		  </li>
		</ul>
	  </div>
  
</div><!-- .page-wrap -->


<div class="page-sidebar col-sm-4" role="complementary">

  <aside id="gform_widget-5" class="widget gform_widget"><h3 class="widget-title">Sign up for our newsletter</h3><link rel='stylesheet' id='gforms_reset_css-css'  href='https://alabamanewscenter.com/wp-content/plugins/gravityforms/css/formreset.min.css?ver=2.4.8' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_formsmain_css-css'  href='https://alabamanewscenter.com/wp-content/plugins/gravityforms/css/formsmain.min.css?ver=2.4.8' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_ready_class_css-css'  href='https://alabamanewscenter.com/wp-content/plugins/gravityforms/css/readyclass.min.css?ver=2.4.8' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_browsers_css-css'  href='https://alabamanewscenter.com/wp-content/plugins/gravityforms/css/browsers.min.css?ver=2.4.8' type='text/css' media='all' />

                <div class='gf_browser_unknown gform_wrapper' id='gform_wrapper_8' ><div id='gf_8' class='gform_anchor' tabindex='-1'></div><form method='post' enctype='multipart/form-data'  id='gform_8'  action='/2019/05/05/day-alabama-history-neil-bonnett-makes-nascar-debut/#gf_8'>
                        <div class='gform_body'><ul id='gform_fields_8' class='gform_fields top_label form_sublabel_below description_below'><li id='field_8_1'  class='gfield gfield_html gfield_html_formatted gfield_no_follows_desc field_sublabel_below field_description_below gfield_visibility_visible' ><style>
a.button, input.button {
    background-color: #dc1f28;
    border: 1px solid #dc1f28;
    color: #ffffff;
    text-align: center;
    text-decoration: none;
    padding: 10px 30px 8px !important;
}
a.button:hover, input.button:hover {
    background-color: #ff242e;
    color: #ffffff !important; 
}
form input[type="text"], form input[type="email"] {
    background: white none repeat scroll 0 0;
    border: 1px solid #d4d7da;
    border-radius: 3px;
}
.gform_wrapper .gform_footer {
    margin: 0.625em 0 0 !important ;
   padding: 0em 0 0.625em !important;
}

</style>
</li><li id='field_8_2'  class='gfield gf_left_half gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_8_2' >Your name<span class='gfield_required'>*</span></label><div class='ginput_container ginput_container_text'><input name='input_2' id='input_8_2' type='text' value='' class='medium'   tabindex='1'  aria-required="true" aria-invalid="false" /></div></li><li id='field_8_3'  class='gfield gf_right_half gfield_contains_required field_sublabel_below field_description_below gfield_visibility_visible' ><label class='gfield_label' for='input_8_3' >Email<span class='gfield_required'>*</span></label><div class='ginput_container ginput_container_email'>
                            <input name='input_3' id='input_8_3' type='email' value='' class='medium' tabindex='2'   aria-required="true" aria-invalid="false" />
                        </div></li>
                            </ul></div>
        <div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_8' class='gform_button button' value='Sign up' tabindex='3' onclick='if(window["gf_submitting_8"]){return false;}  if( !jQuery("#gform_8")[0].checkValidity || jQuery("#gform_8")[0].checkValidity()){window["gf_submitting_8"]=true;}  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_8"]){return false;} if( !jQuery("#gform_8")[0].checkValidity || jQuery("#gform_8")[0].checkValidity()){window["gf_submitting_8"]=true;}  jQuery("#gform_8").trigger("submit",[true]); }' /> 
            <input type='hidden' class='gform_hidden' name='is_submit_8' value='1' />
            <input type='hidden' class='gform_hidden' name='gform_submit' value='8' />
            
            <input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
            <input type='hidden' class='gform_hidden' name='state_8' value='WyJbXSIsIjRkMTUyM2YwZTFhODE2N2UwZjhiOGE5MGYyY2EzZjkxIl0=' />
            <input type='hidden' class='gform_hidden' name='gform_target_page_number_8' id='gform_target_page_number_8' value='0' />
            <input type='hidden' class='gform_hidden' name='gform_source_page_number_8' id='gform_source_page_number_8' value='1' />
            <input type='hidden' name='gform_field_values' value='' />
            
        </div>
                        </form>
                        </div></aside><aside id="popular_posts_widget-5" class="widget widget_popular_posts_widget"><h3 class="widget-title">Popular Stories</h3>          <div class="popular-post-box">
            <div class="popular-post-image">
              <a href="https://alabamanewscenter.com/2019/04/29/chad-nelson-is-an-alabama-maker-putting-mugs-on-mugs/" class="pull-left" data-ga-category="Post_Widget_Popular" data-ga-label="Chad_Nelson_Is_An_Alabama_Maker_Putting_Mugs_On_Mugs" data-ga-action="Click"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/04/UgChugsFeature-320x180.jpg" alt="" /></a>
            </div>
            <div class="popular-post-text">
              <h6><span class="em em-business">Business</span></h6>
              <a href="https://alabamanewscenter.com/2019/04/29/chad-nelson-is-an-alabama-maker-putting-mugs-on-mugs/" data-ga-category="Post_Widget_Popular" data-ga-label="Chad_Nelson_Is_An_Alabama_Maker_Putting_Mugs_On_Mugs" data-ga-action="Click">Chad Nelson is an Alabama Maker putting mugs on mugs</a>
            </div>
          </div>
                    <div class="popular-post-box">
            <div class="popular-post-image">
              <a href="https://alabamanewscenter.com/2019/04/30/alabamas-literary-capital-honors-authors-with-new-sculpture-trail/" class="pull-left" data-ga-category="Post_Widget_Popular" data-ga-label="Alabamas_Literary_Capital_Honors_Authors_With_New_Sculpture_Trail" data-ga-action="Click"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/04/Literary-Sculpture-Trail-FEATURE-320x180.jpg" alt="" /></a>
            </div>
            <div class="popular-post-text">
              <h6><span class="em em-community">Community</span></h6>
              <a href="https://alabamanewscenter.com/2019/04/30/alabamas-literary-capital-honors-authors-with-new-sculpture-trail/" data-ga-category="Post_Widget_Popular" data-ga-label="Alabamas_Literary_Capital_Honors_Authors_With_New_Sculpture_Trail" data-ga-action="Click">Alabama's Literary Capital honors authors with new sculpture trail</a>
            </div>
          </div>
                    <div class="popular-post-box">
            <div class="popular-post-image">
              <a href="https://alabamanewscenter.com/2019/04/29/alabama-power-lineman-spotlight-chris-jackson/" class="pull-left" data-ga-category="Post_Widget_Popular" data-ga-label="Alabama_Power_Lineman_Spotlight_Chris_Jackson" data-ga-action="Click"><img src="https://alabamanewscenter.com/wp-content/uploads/2019/04/Chris-Jackson-Feature-320x180.jpg" alt="" /></a>
            </div>
            <div class="popular-post-text">
              <h6><span class="em em-about-us">About Us</span></h6>
              <a href="https://alabamanewscenter.com/2019/04/29/alabama-power-lineman-spotlight-chris-jackson/" data-ga-category="Post_Widget_Popular" data-ga-label="Alabama_Power_Lineman_Spotlight_Chris_Jackson" data-ga-action="Click">Alabama Power lineman spotlight: Chris Jackson</a>
            </div>
          </div>
          </aside><aside id="archive_widget-4" class="widget widget_archive_widget"><h3 class="widget-title">Monthly Archive</h3>    <select id="apc_archive_year" class="apc-archive-year">
      <option value="">Select year</option>
      <option value="2019" >2019</option><option value="2018" >2018</option><option value="2017" >2017</option><option value="2016" >2016</option><option value="2015" >2015</option><option value="2014" >2014</option><option value="2013" >2013</option><option value="2012" >2012</option>    </select>
    <select id="apc_archive_month" class="apc-archive-month" disabled="disabled">
      <option value="">Select month</option>
      <option value="01" >January</option><option value="02" >February</option><option value="03" >March</option><option value="04" >April</option><option value="05" >May</option><option value="06" >June</option><option value="07" >July</option><option value="08" >August</option><option value="09" >September</option><option value="10" >October</option><option value="11" >November</option><option value="12" >December</option>    </select>
    <!-- <button id="apc_archive_search" class="btn btn-archive" disabled="disabled">View Archives</button> -->
    <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
    jQuery(document).ready(function($) {

      
      var year = $('#apc_archive_year').val();
      $('#apc_archive_year').on('change', function(){
        year = $(this).val();
        if(year != ''){
          $('.apc-archive-month option:selected').removeAttr('selected');
          $('#apc_archive_month').removeAttr('disabled');
        } else {
          $('#apc_archive_month').attr('disabled', 'disabled');
        }
      });

      $('.apc-archive-month').on('change', function(){
        var month = $(this).val();
        var url = "https://alabamanewscenter.com/"+year+'/'+month;
        if(typeof url == "undefined") {
          $(this).attr('disabled', 'disabled');
        } else {
          document.location.href = url;
        }
      });

      // $('#apc_archive_search').on('click', function(){
      //   var url = $('.apc-archive-month:visible').val();
      //   if(typeof url == "undefined") {
      //     $(this).attr('disabled', 'disabled');
      //   } else {
      //     document.location.href = url;
      //   }
      // });
    });
    </script>
    </aside><aside id="wptt_twittertweets-11" class="widget wptt_TwitterTweets"><h3 class="widget-title">Twitter</h3>        <ul class="fetched_tweets">
          
            <li class="tweets_avatar">
              <div class="tweet_wrap">
                <div class="times">
                  Alabama Power | <a href="https://www.twitter.com/alabamapower" target="_blank" title="Follow alabamapower on Twitter [Opens new window]">@alabamapower</a> | Thursday May 2 - 6:00pm                </div>
                <div class="tweet_data">
                  Safety Tip: Never overload an electrical socket or extension cord with too many plugs. <a href="https://twitter.com/search?q=%23SafetyFirst" target="_blank" rel="nofollow">#SafetyFirst</a> <a href="https://t.co/PtQv1o0L8d" target="_blank" rel="nofollow">https://t.co/PtQv1o0L8d</a>                </div>
              </div>
            </li>

          
            <li class="tweets_avatar">
              <div class="tweet_wrap">
                <div class="times">
                  Alabama Power | <a href="https://www.twitter.com/alabamapower" target="_blank" title="Follow alabamapower on Twitter [Opens new window]">@alabamapower</a> | Tuesday Apr 30 - 9:00am                </div>
                <div class="tweet_data">
                  Meet Chris Jackson, an Alabama Power lineman from Eufaula, Alabama who has a passion for giving back to his communi… <a href="https://t.co/Gkf0K5ncNZ" target="_blank" rel="nofollow">https://t.co/Gkf0K5ncNZ</a>                </div>
              </div>
            </li>

          
            <li class="tweets_avatar">
              <div class="tweet_wrap">
                <div class="times">
                  Alabama Power | <a href="https://www.twitter.com/alabamapower" target="_blank" title="Follow alabamapower on Twitter [Opens new window]">@alabamapower</a> | Friday Apr 26 - 4:00pm                </div>
                <div class="tweet_data">
                  Our team recently enjoyed helping more than 100 young girls with hands-on engineering activities at the iCan confer… <a href="https://t.co/UnZfKDm0RB" target="_blank" rel="nofollow">https://t.co/UnZfKDm0RB</a>                </div>
              </div>
            </li>

          
        </ul>

        </aside><aside id="rss_feed_widget-6" class="widget widget_rss_feed_widget">
      <div class="widget-image"></div>
      <div class="widget-inner">
        <h3 class="widget-title">RSS</h3>
        <p class="widget-text">Another way to get Alabama NewsCenter content.</p>
        <div class="alert-buttons">
          <a class="btn btn-rss " target="_blank" href="https://alabamanewscenter.com/feed/">Subscribe to RSS</a>
        </div>
      </div></aside>
</div><!-- #page-sidebar -->
      </div><!-- .content-row -->
    </div><!-- #site-content -->
  </div><!-- .back-wrap -->

  <footer id="site-footer" role="contentinfo">

      <nav class="global-nav footer-nav" role="navigation">

        <div class="container-fluid footer-primary">
          <div class="col-xs-12 footer-top-links">
            <ul id="social-nav" >
                          </ul>
            <ul id="footer-corp-links">
            <li class="copyright">&copy 2019 Southern Company</li><li class="menu-terms-of-use"><a target="_blank" href="http://www.southerncompany.com/legal/home.cshtml" data-ga-category="Global_Footer" data-ga-action="Click" data-ga-label="Terms_Of_Use">Terms of Use</a></li>
<li class="menu-privacy-statement"><a target="_blank" href="http://www.southerncompany.com/legal/privacy-statement.cshtml" data-ga-category="Global_Footer" data-ga-action="Click" data-ga-label="Privacy_Statement">Privacy Statement</a></li>
<li class="menu-smartneighbor"><a href="https://www.smartneighbor.com/" data-ga-category="Global_Menu" data-ga-action="Click" data-ga-label="Smartneighbor">Smartneighbor</a></li>
<li class="menu-developed-by-alabama-power"><a href="http://alabamapower.com/" data-ga-category="Global_Menu" data-ga-action="Click" data-ga-label="Developed_By_Alabama_Power">Developed by Alabama Power</a></li>
            </ul>
          </div>
          <div class="col-xs-12 footer-bottom-links">
            <ul>
            
      <li class="menu-business" data-cat="business">
      <a class="cat-head" href="https://alabamanewscenter.com/category/business/" data-ga-category="Global_Menubar" data-ga-action="Click" data-ga-label="Business">Business</a></li>

      <li class="current-post-ancestor active current-post-parent menu-community" data-cat="community">
      <a class="cat-head" href="https://alabamanewscenter.com/category/community/" data-ga-category="Global_Menubar" data-ga-action="Click" data-ga-label="Community">Community</a></li>

      <li class="menu-innovation" data-cat="innovation">
      <a class="cat-head" href="https://alabamanewscenter.com/category/innovation/" data-ga-category="Global_Menubar" data-ga-action="Click" data-ga-label="Innovation">Innovation</a></li>

      <li class="menu-weather-center" data-cat="weather-center">
      <a class="cat-head" href="https://alabamanewscenter.com/category/weather-center/" data-ga-category="Global_Menubar" data-ga-action="Click" data-ga-label="Weather_Center">Weather Center</a></li>

      <li class="menu-about-us">
      <a href="https://alabamanewscenter.com/about-us/" data-ga-category="Global_Menubar" data-ga-action="Click" data-ga-label="About_Us">About Us</a></li>
            </ul>
          </div>

        </div>

      </nav><!-- #site-navigation -->

  </footer><!-- #site-footer -->


<!-- START Parse.ly Include: Standard -->

<div id="parsely-root" style="display: none">
	<div id="parsely-cfg" data-parsely-site="alabamapowernews.com"></div>
</div>
<script data-cfasync="false">
	(function (s, p, d) {
		var h = d.location.protocol, i = p + "-" + s,
			e = d.getElementById(i), r = d.getElementById(p + "-root"),
			u = h === "https:" ? "d1z2jf7jlzjs58.cloudfront.net"
				: "static." + p + ".com";
		if (e) return;
		e = d.createElement(s);
		e.id = i;
		e.async = true;
		e.setAttribute('data-cfasync', 'false');
		e.src = h + "//" + u + "/p.js";
		r.appendChild(e);
	})("script", "parsely", document);
</script>

<!-- END Parse.ly Include: Standard -->
	<div style="display:none">
	</div>
<link rel='stylesheet' id='slickquiz_css-css'  href='https://alabamanewscenter.com/wp-content/plugins/slickquiz/slickquiz/css/slickQuiz.css?ver=4.9.10' type='text/css' media='all' />
<link rel='stylesheet' id='slickquiz_front_css-css'  href='https://alabamanewscenter.com/wp-content/plugins/slickquiz/css/front.css?ver=4.9.10' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201919'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var qpprFrontData = {"linkData":[],"siteURL":"https:\/\/alabamanewscenter.com","siteURLq":"https:\/\/alabamanewscenter.com"};
/* ]]> */
</script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js?ver=5.1.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pollsL10n = {"ajax_url":"https:\/\/alabamanewscenter.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.2'></script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-content/themes/news/assets/js/plugins.min.js?ver=20190505'></script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-content/themes/news/assets/js/main.min.js?ver=20190505'></script>
<script type='text/javascript' src="https://maps.google.com/maps/api/js?key=AIzaSyBPSevgKVgRMPHRjIXc6ZAay_Ph-zo-QcU&#038;libraries=places&#038;region=us&#038;language=en&#038;sensor=false"></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/fitvids/1.1.0/jquery.fitvids.min.js'></script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-content/themes/news/assets/js/bootstrap-touch-carousel.js'></script>
<script type='text/javascript' src='//cdnjs.cloudflare.com/ajax/libs/swfobject/2.2/swfobject.min.js'></script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-includes/js/wp-embed.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/alabamanewscenter.com\/wp-admin\/admin-ajax.php","nonce":"d75a08854b","display_exif":"0","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/alabamanewscenter.com\/wp-login.php?itsec-hb-token=wearepr&redirect_to=https%3A%2F%2Falabamanewscenter.com%2F2019%2F05%2F05%2Fday-alabama-history-neil-bonnett-makes-nascar-debut%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-content/plugins/jetpack/_inc/build/tiled-gallery/tiled-gallery/tiled-gallery.min.js?ver=4.9.10'></script>
<script type='text/javascript' src='https://alabamanewscenter.com/wp-content/plugins/slickquiz/slickquiz/js/slickQuiz.js?ver=4.9.10'></script>
<script type='text/javascript'> jQuery(document).bind('gform_post_render', function(event, formId, currentPage){if(formId == 8) {} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} );</script><script type='text/javascript'> jQuery(document).ready(function(){jQuery(document).trigger('gform_post_render', [8, 1]) } ); </script><script type='text/javascript' src='https://stats.wp.com/e-201919.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.1.1',blog:'91832812',post:'180320',tz:'-5',srv:'alabamanewscenter.com'} ]);
	_stq.push([ 'clickTrackerInit', '91832812', '180320' ]);
</script>

  <script type="text/javascript">
    var switchTo5x=true;
    var __st_loadLate=true;
    jQuery(".mobile-share").fancybox();
  </script>
  <script type="text/javascript" src="https://ws.sharethis.com/button/buttons.js"></script>
  <script type="text/javascript">stLight.options({publisher: "14e83348-bf48-4b36-8261-924a3f925f89", doNotHash: false, doNotCopy: false, hashAddressBar: false, onhover: false});</script>

   <!-- Adobe DTM -->
   <script type="text/javascript">_satellite.pageBottom();</script>

</body>
</html>
